Duplicate tracks moves notes


When I duplicate a track in the new organize tracks view, it deletes all notes from the source track. It used to not do that, so I was a little surprised and confused when I noticed.

I usually duplicate tracks to either separate low and high frequencies or to make a different chop. In any case, I don’t want the notes from the source track to be deleted.

It should either not delete the notes, ask me if I want to delete them or there should be an option somewhere to not delete them by default.


Also, why does it duplicate the sound file?

Maybe there should also be an option to use the same sound file by default.

1 Like

Eek. I’m pretty sure deleting notes from the original track is a bug. Reported, thanks!

1 Like

Do you have fixup pattern turned on? The F1 key will be illuminated if it is.
Duplicate will move the pattern events to the new, duplicated, track if fixup is on, and not move them if it is off.


Oh, and the way the S2400 works is that each track always has its own sound file. That is why the file is copied when you duplicate a track.


Hey @Mickey, toggling the F1 key did the trick, thanks.