Input Monitor shortcut doesn’t work from start

Double clicking the Input Monitor button does nothing until input monitor has been activated at least once manually.

Note that after activating the check box manually you have to leave the menu. Activating, then deactivating, then exiting the menu will not make the shortcut work.

I think I’ve solved the mystery. From the start, the shortcut works for USB audio input. Then, after the Analog audio input has been toggled, the shortcut starts to work for it too. Still don’t understand the logic completely though.

@Mickey could you please add a popup message so that the user could see which input exactly is activated/deactivated after executing the shortcut? More popups!

As there are two types of input monitoring (analog and digital via USB), the user is

Cleaning this up and adding a popup.

@kulturhaus Question:
If both analog and usb monitoring are off when the machine starts, what should happen on the first double-click? Turn them both on? Currently, there is no change since there was no previous on state.

1 Like

The cleanest solution would probably be to specify somewhere in the settings what exactly should be toggled (Analog, Digital or both), thus ignoring the previous on states completely. But then this doesn’t feel intuitive to me.

With the contextual toggling you’ve implemented, I’d say if nothing is selected, toggle them both (with a proper popup notification, e.g. “All inputs active”). This seems the most logical to me.

1 Like

What about a user preference setting stored in the SET file so that it is loaded at each startup?