Incorrect directories created when loading project/kit from a formatted SD Card

Here’s a new one from today

Description

Incorrect direcories are being created and navigated to when attempting to load a project or a kit from a freshly formatted SD Card on S2400.

Steps to reproduce

  1. Format SD Card on the device
  2. Go to File > Load Project
  3. Observe the result. You are inside a directory with a gibberish name. This directory is in root directory of SD Card.
  4. Go to File > Load kit
  5. Observe the result. You are inside another directory with a gibberish name also in the root directory of SD Card.

Discussion

ls -al output demonstrating “load project” case:

╰─ ls -al
total 68
drwxr-xr-x  3 cfd2       cfd2     32768 Dec 31  1969 .
drwxr-x---+ 3 root       root      4096 Aug 29 21:03 ..
drwxr-xr-x  2 cfd2       cfd2    232768 Jun  6  2015 R‡“ð²DøÊLv—e´Ý

I understand that projects are stored in PROJECTS/ directory and kits are stored in KITS/ neither of which currently exist on the SD Card due it having been formatted seconds before. So how do we end up in those weird dirs?

The generated name of created dir is always different.

Firmware:

24 Feb 2022, release

1 Like

I get that 100% of the time, ever since the last FW and ever since my newly bought SD card (which I filled up all the way)… not in Load Projects tho… I get it after dumping a lot of sample-files into a brand new and newly formatted SD card, and trying to preview/load the sounds.

File Menu > Load Sounds Folder > SD Card > there’s a mystery empty jibberjabber folder made.

Also happens in:

  • Load Kit
  • Browse Files (additionally, the other normal [Projects/Samples-Archive/S2400.SET] folders disappear after clicking on the jibberjabber-folder and then hitting Back [last pic])

Never reported it… as I was thinking it may be my SD card or user-error, because it is a Sandisk 256gb and I totally filled it up w/ no headroom to spare at all (will it run correctly if totally full?). So, maybe the SD card being totally full is causing it, irdk.

Also, I just haphazardly dumped tons of sample files and folders into the SD card, without even filtering/removing the files that the S2400 isn’t designed to read (hfe, rex, mp3, aiff, zip, cue, bin, iso, jpg jpeg (cover art pics), etc., etc., lol)
I was lazy to remove them odd files before dumping into the SD card (since tons and tons of samples/files/folders; and I just wanted to get it up and running to test it out)… but, idk if that would negatively affect the S2400. Will all those odd files in the SD card disrupt the S2400?

I plan to clean it all up tho in the near future - remove all those files the S2400 cannot read and then reformatting SD, redoing and redumping files that the S2400 is compatible with.

r

1 Like

Hmmm, interesting. It could be many things. In your case, the issue needs to be isolated. Although, it’s possible that it’s somehow related to the issue that I reported.

To answer your question, in my opinion, files are just files. If a file type is not supported by S2400, then it should simply be ignored. I’d be surprised if it worked any different.

My SD Card is proven to be working just fine (in case anyone has doubts) and I have been using it since November FW. I just wanted to format it and get rid of the old settings file to see if it would resolve my issue that we discussed in another thread the other day. So my SD Card is actually empty and does not contain any file whatsoever as you can see by the output of ls -al. You can observe this issue with weird dirs being created when the card has just been formatted.

Basically, format it and go load a project right away (you don’t really have a project but do it anyway).

I have put back my project files and the unit still does the same thing like you said. It created two more directories — one when loading a project and another when loading a kit. This time I obviously have PROJECTS/ directory.

I have maybe 12 projects in total and they are fairly small. I don’t have many samples on my SD Card either (just a couple of well-known drum machines). There is nothing else on the SD Card, no hidden files, too.

Last time (prior to yesterday, of course) my SD Card was formatted was when I got my S2400 in October. I’m not sure if anything has changed since then in terms of formatting.

When I remove the SD card, the weird jibberjabber directories are now gone.
But… once I insert SD card again… those weird Predator jibberjabber directories return.

So… perhaps it’s got something to do with the SD card (too full and/or incompatible files in it?) or how the S2400 reads them?


0

1 Like

Sure, because I don’t think we can create directories or write to internal memory.

It’s definitely not the former because it is happening to me when the SD Card is completely empty. The issue started happening to me once I formatted the SD Card in the current software version.

1 Like

Yeah… It never happened before the latest FW; it was fine last year.

But, I’m also not sure if it only started happening after I totally filled up the SD card and also with weird incompatible files. Iirc, it started happening after I did those things too.

But yeah… it could be the SET file too.

@rozz3r is there a reason why this topic isn’t [IN PROGRESS] anymore?

1 Like

I got a new Transcend 512gb SD card (previous one was a Sandisk 256gb, the cheaper gold one).

First, I only loaded it with 1 single folder of WAV files only, cuz I wanted to test it with only the correct compatible files and make sure the previous SD card with a bunch of random misc. files weren’t causing the prob. But, it still made those random folders with weird directory names.

The random folders with weird directory names look a bit different than the last SD card, and are also now in different areas of the menus. It now happens/shows in Load Project, Load Kit, Load Sounds Folder and Browse Files.

Prolly not a huge deal and you can easily just ignore them and work away. So I guess it’s just a problem aesthetically. Still looks buggy and messy tho.

I already tried reformatting SD and retrying +5x. Still same issue with randomly made folders w/ weird directory names.

Screen Shot 2022-10-14 at 9.26.09 AM

1 Like

I’m still curious about the status of this ticket. I’m gonna flip out if I hear that it’s my SD Card again

(It’s not)

2 Likes