Possible bug copying midi only tracks [IN PROGRESS]

Came across this issue:

-When copying a track with only midi data in step program using copy+pad the unit says it has copied the data
-When trying to paste this in a different pattern it says ‘nothing clipped’ using paste (F7) However i can choose paste and replace and it will paste the midi data in the pattern (obviously replacing all other existing tracks, what i really want is paste and merge which is unavailable as an option)
-When copying all tracks and selectively pasting the midi track in a different pattern i can only choose between sample banks and not midi tracks.

Current workaround is copying the midi data with paste and replace in an empty pattern set to the correct length and then copying the pattern i want the midi data to be merged with using paste and merge in the midi data only pattern i just created (basically the reverse order of what one would normally do).

Thanks for your reply!

1 Like

I can recreate this bug as well.