Freeze after copying track [IN PROGRESS]

Hi guys, trying out the new firmware but getting some freezes. Here’s what I did:

  • sample a sound + assign to track (in this case A4)
  • copy track to a couple of new tracks (A5, A6, A7, A8)
  • start slicing the samples

Doing the editing or triggering the samples, my machine freezes. Also, after copying the track to a new track and saving, sometimes after loading the project again, the new track doesn’t playback right (just a clicky sound) and the machine freezes again.

Anyone else have this problem?

Not able to reproduce this.

If you check the Project folder after saving, are the original sample and its copies saved correctly? Or it is just a click there too?

The original sample and the copies seem to be saved correctly. They play back fine when browsing in the file menu. Some load correctly and slicing works fine. Some don’t load correctly. When opening the wave editor with those (loop/slice and B) the machine freezes.

Do you want me try with another project/sample?

Please zip the project folder and put it on google drive or drop box and post the link here.

I ran into a similar situation. I did not sample, but loaded some samps:

  • load sample to A1
  • multi edit slices
  • copy to A1 to A2
  • load sample to A3
  • reassign another sample to A1

Result was that A1 and A3 had only clicking sounds. No crash though.

Inspecting the situation made clear that the sample start of A1 appeared to be correct (oneshot, with start on 0 and end at the end of the sample). But triggering it from the pad gave me a very short click. I then moved the startpoint from 0 to something larger than 0. Now the oneshot could be triggered again. Moving the start back to 0 resolved the issue of A1.

A3 was slightly different. This oneshot had it’s starting point being moved to the right (near the middle). Solution was to move it to 0 again.

Next time I get into this, I’ll save the project when it is in crooked state. Right now, it has probably is useless.

Sorry, something went wrong with the link. Here’s a new try:

I’m getting some freezes and I think it’s probably this bug reported by @mikeengels

I’m not sure if all of these steps are essential but I can reproduce as follows:

  1. Assign a longish sample (30 seconds plus) to pad 1
  2. Assign the same sample to pad 2
  3. Press loop/slice and B button 1 to get to the waveform slice editor.
  4. Use fader 1 to shift sample start slightly forward for pad 1
  5. Hit pad 2 and then use fader 1 to shift sample start significantly more forward of where sample start was set for pad 1
  6. Hit pad 1 then before the pad 1 play head reaches the point where pad 2 sample start is set, hit pad 2.
  7. S2400 freezes.

I hope that makes sense, let me know if you need a better explanation. Appears to be reliably reproducible and not related to any specific sample.

Bug confirmed here.
Following your step by step it freezes when reloading the waveform for pad 2 here.

By the way curious to know: is there a reason why you don’t use multislices in this case? multislices seems to work fine and be appropriate in case of different start points.

It might be something caused by faders. I tried to do the same with the encoder and looked fine.

My thought also. It seems like the fader catch-up algorithm is having troubles after copying pads to other pads, maybe?

1 Like

By the way curious to know: is there a reason why you don’t use multislices in this case? multislices seems to work fine and be appropriate in case of different start points.

Those steps were the easiest example I could give after I figured out how to reproduce it, rather than any workflow I use.

I first encountered the bug when chopping a sample. I accidentally hit the wrong pad and the machine froze.

It might be something caused by faders. I tried to do the same with the encoder and looked fine.

You might be on the money here. I can reproduce the freeze using the encoder to set the start points and with the fader somewhere non-zero.

With the fader at zero, and setting the start points using the encoder, the crash doesn’t seem to happen.

1 Like

Hi guys, starting a new project I bumped into the same bug again. Just in case it’s useful, here are my exact steps:

  • create a new project
  • sample a sound and assign to A1
  • adjust slice start and ending
  • copy sound from A1 to A2 (hitting copy button, pad A1 and then A2)
  • adjust slice A2 start and ending points
  • copy sound from A1 to A3
  • adjust slice A3 start and ending
    (up to here everything seems ok)
  • saving file
  • hitting pad A3 the sample does not play
  • entering loop/slice and graphical editor (button B): machine freezes

When assigning sounds, the saved samples black normal (from the assign sound portion of the track settings menu)

In the whole process I didn’t touch the faders. Slicing was done with the encoder.

Hope this helps.

Tried the latest firmware yesterday and also ran into this freeze after trying to copy pad A1 to B1. I had originally assigned samples to pads A1 and A8 and fooled around with various parameters (Pitch, Loop) on both. I then decided to move A1 > B1 and A8 > B2, and it froze while copying A1 > B1.

@mikeengels In step 8, you say “saving file”. Do you mean saving the truncated sample (not the project)? If so, then that pinpoints where the problem is. More than one track is pointing to the same file, then that file gets overwritten. We will work on that bug. In the meantime, if you save the project first, then it will make copies of the sound, and this bug will not occur.

1 Like

@Mickey I actually meant saving the project. I didn’t save the truncated sample. My project folder also contains the copies of the sample and they play back fine when accessed from the assign sound menu. So I’m guessing this might still be another issue? Thanks for looking into this.

Hi guys, a little update here although I will also make a support ticket.

I encountered the same issue without any copying of samples to different tracks. Just sampling, saving the project and reopening it. Result: track won’t play, machine freezes when entering the sample editor.

What I also discovered: with the faulty sample/track, when I go into loop/slice mode first (not the graphical sample editor) and touch the fader (changing the starting point of the sample) the track comes back to life: meaning it plays back again, Then I can enter the graphical editor and everything seems to work fine. No freezes. When I save the project after this and open it again, it’s back to the same problem: track won’t play, machine freezes when I open the sample editor.

Thanks for the additional info. That will help.

Have recreated the Loading bug here, thanks to everyone in the thread for reporting. It’s with @mickey now.

2 Likes